pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/43471: wrong dependencies for gtk2

>Number:         43471
>Category:       pkg
>Synopsis:       wrong dependencies for gtk2
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Mon Jun 14 17:35:00 +0000 2010
>Originator:     Tim Larson
>Release:        NetBSD 5.0.2
NetBSD 5.0.2 NetBSD 5.0.2 (GENERIC) #0: Sat Feb  6 17:53:27 
UTC 2010
Newest gtk2 in pkgsrc (updated cvs 2010jun14) doesn't list right dependencies.  

checking for BASE_DEPENDENCIES... configure: error: Package requirements 
(glib-2.0 >= 2.23.6    atk >= 1.29.2    pango >= 1.20    cairo >= 1.6) were not 

Requested 'glib-2.0 >= 2.23.6' but version of GLib is 2.22.3
Requested 'atk >= 1.29.2' but version of Atk is 1.28.0

In the Makefile,

BUILDLINK_API_DEPENDS.atk+=    atk>=1.13.0
BUILDLINK_API_DEPENDS.glib2+=  glib2>=2.21.3

Run cvs update, then try to build gtk2.
Updating the gtk2 Makefile BUILDLINK_API_DEPENDS with the versions listed above 
ought to do it.  I did this, and gtk is building now.

Home | Main Index | Thread Index | Old Index