pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42316: perl isn't compiled under FreeBSD 8.0-RC2

>Number:         42316
>Category:       pkg
>Synopsis:       perl isn't compiled under FreeBSD 8.0-RC2
>Confidential:   no
>Severity:       critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Nov 14 09:40:00 +0000 2009
>Originator:     Alexey Lebedev
>Release:        FreeBSD 8.0-RC2
System: FreeBSD 8.0-RC2 FreeBSD 8.0-RC2 #0: Wed Nov  4 
08:05:55 MSK 2009  amd64
Architecture: x86_64
Machine: amd64
   lang/perl fails to compile with this message:

   Which of these apply, if any? [freebsd]  

   Some users have reported that Configure halts when testing for
   the O_NONBLOCK symbol with a syntax error.  This is apparently a
   sh error.  Rerunning Configure with ksh apparently fixes the
   problem.  Try
        ksh Configure [your options]

   Operating system name? [freebsd]  
   Operating system version? [8.0-rc2]  
   Installation prefix to use? (~name ok) [/usr/pkg]  
   AFS does not seem to be running...
   What installation prefix should I use for installing files? (~name ok)
   Build Perl for SOCKS? [n]  
   Use the PerlIO abstraction layer? [y]  
   Getting the current patchlevel...
   Build a threading Perl? [y]  
   POSIX threads should be supported by FreeBSD 8.0-rc2 --
   but your system is missing the shared libc_r.
   (/sbin/ldconfig -r doesn't find any).

        cd /usr/pkgsrc/lang/perl5; bmake

Home | Main Index | Thread Index | Old Index