pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/41943 (readline 6.0 is GPLv3.)

The following reply was made to PR pkg/41943; it has been noted by GNATS.

From: Takahiro Kambe <>
Subject: Re: pkg/41943 (readline 6.0 is GPLv3.)
Date: Wed, 02 Sep 2009 16:17:10 +0900 (JST)

 In message <>
        on Wed,  2 Sep 2009 07:06:56 +0000 (UTC), wrote:
 > Synopsis: readline 6.0 is GPLv3.
 > State-Changed-From-To: closed->analyzed
 > State-Changed-By:
 > State-Changed-When: Wed, 02 Sep 2009 07:06:54 +0000
 > State-Changed-Why:
 > guess we need a gplv2 readline package.
 > (or can ruby be made to use libedit?)
 There are several points.
 1. readline 6.0 is under GPLv3 and LICENSE has fixed.
 2. Discussion is continued and no explicit result yet.
 3. ruby18-readline package already uses libedit if available.  But
    compared with readline, libedit lacks some functions and support of
    multibyte characters.  I didn't realized about multibyte characters
    and I'll add an option which select readline library to
 So, something safer solution might be keeping readline<6.0...
 Takahiro Kambe <>

Home | Main Index | Thread Index | Old Index