[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
The following reply was made to PR pkg/39890; it has been noted by GNATS.
From: Takahiro Kambe <taca%back-street.net@localhost>
Subject: Re: pkg/39890
Date: Fri, 28 Nov 2008 14:42:22 +0900 (JST)
I missed the reply to this PR.
In message <20081120230006.E3A2163B8BD%narn.NetBSD.org@localhost>
on Thu, 20 Nov 2008 23:00:06 +0000 (UTC),
"Michal Suchanek" <hramrach%centrum.cz@localhost> wrote:
> > > The Ruby 1.8.7 available in pkgsrc is not 1.8 compatible.
> > If you build Ruby 1.8.7 out side of pkgsrc framework, "not 1.8
> > compatible" problem will be gone a way? If not,
> No, it does not.
Thanks. It confirmed that the problem isn't pkgsrc specific problem.
> > > While most 1.8 code runs in 1.8.7 with only minor tweaks lots of 1.8.7
> code would not run in older 1.8 rubies which makes 1.8.7 completely
> unsuitable for Ruby development.
> > These problems are inherently the problem of Ruby itself. AFAIK, many
> No, it is not. 1.8.6 is readily available on the Ruby web site.
I never said that Ruby 1.8.6 isn't available any more. Compatibility
problems are because of Ruby itself, not pkgsrc.
> > Ruby programs are updated to supoprt newer Ruby 1.8.7 (or 1.9 preview).
> Yes. I do not doubt that. On the other hand, I have not heard of a
> program that requires 1.8.7. And code written for 1.8.7 (using 1.8.7
> documentation) has high chance of failing on 1.8.6 or earlier.
So, we can't simply downgrade pkgsrc's Ruby to 1.8.6.
And providing a separate 1.8.6 package, I won't work on it because of
the costs of changing current frame work of ruby in pkgsrc.
(And there a few points to be considered, such as pkgsrc's directory
or package name of ruby's extentioin packages.)
But if anyone have a good patch, I don't object to incorporate it.
Takahiro Kambe <taca%back-street.net@localhost>
Main Index |
Thread Index |