pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/39890

The following reply was made to PR pkg/39890; it has been noted by GNATS.

From: "Michal Suchanek" <>
Subject: Re: pkg/39890
Date: Tue, 25 Nov 2008 02:07:39 +0100

 2008/11/21 Bernd Ernesti <>:
 > The following reply was made to PR pkg/39890; it has been noted by GNATS.
 > From: Bernd Ernesti <>
 > To:
 > Cc:
 > Subject: Re: pkg/39890
 > Date: Fri, 21 Nov 2008 07:44:37 +0100
 >  On Thu, Nov 20, 2008 at 11:00:06PM +0000, Michal Suchanek wrote:
 >  [..]
 >  >  >  Ruby programs are updated to supoprt newer Ruby 1.8.7 (or 1.9 
 > preview).
 >  >
 >  >  Yes. I do not doubt that. On the other hand, I have not heard of a
 >  >  program that requires 1.8.7. And code written for 1.8.7 (using 1.8.7
 >  >  documentation) has high chance of failing on 1.8.6 or earlier.
 >  Code written for 1.8.6 have a much higher chance to fail once 1.9 is out.
 >  With 1.8.7 you get warnings what you should avoid to get it working with
 >  1.9.
 1.9 is out.
 And code written for anything has high chance to fail once 2.0 is out.
 It is true that 1.8.7 includes some features from 1.9 that were "easy
 enough" to implement on 1.8. That's exactly the problem - it's no
 longer 1.8 as some of the new features break some interfaces commonly
 used in 1.8 but it's still far from 1.9.
 >  >  > >  On some platfroms ruby 1.8.7 is not available and it is not 
 > desirable to install this version for most Ruby users (as far as I can tell 
 > from the ML discussions).
 >  >  > What is the "some platfroms"
 >  >
 >  >  "some platforms" include Windows, and probably packaging systems that
 >  >  are not as eager to pick bleeding edge stuff ;-)
 >  So it is not for an OS which is supported by pkgsrc.
 >  Btw, it it false that 1.8.7 is not supported on Windows.
 >  See where you can get it.
 Yes, the source and a binary build for Windows with no librariees.
 But you can get a package with all the standard lib stuff for WIndows
 that includes based on 1.8.6 there, and you get some 1.8 < 1.8.7
 included in OS X.
 >  Oh, and some packaging system still use an outdated version
 >  with security problems.
 Latest 1.8.6 includes all the security patches latest 1.8.7 does.
 >  >  > and "the ML discussions"?
 >  >  ruby-talk
 >  Provide a pointer to a URL with a statement from a ruby developer.
 What kind of ruby developer? Core ruby developers work on 1.9. There
 is a designated 1.8 maintainer, and a person who wrote 1.8.7.
 And there are people who write libraries, package the interpreter for
 various systems, run, or write software using ruby.
 If you ask the for a statement form the former you will find none.
 They are either not concerned with 1.8 at all or just release stuff.
 If you ask about statement from the later you can find plenty on the
 mailing list.
 >  >  > > >Fix:
 >  >  > > roll back ruby to 1.8.6 or provide a separate 1.8.6 package
 >  >  > Retiring ruby 1.8.7 to 1.8.6 pillage the use of functionality of Ruby
 >  >  > 1.8.7 and I don't think it is realistic approach.
 >  >
 >  >  Packaging an incompatible version of the interpreter does not seem
 >  >  realistic either.
 >  Where is it incompatible?
 >  As mentioned above, you get more problems once 1.9 is out if you use
 >  1.8.6 right now.
 And how you will not get problems if you use 1.8.7? It still differs
 from 1.9 substantially, only a few select features that were easy to
 bolt onto the old interpreter were backported.
 >  And on the url which i mentioned above you see:
 >  The current stable version is 1.8.7.
 >  So why should we go back to another legacy version?
 1.8.6 is not legacy version, it is a stable version which is still
 being maintained.
 1.8.7 is a stable branch of the interpreter with some new features
 implemented which is just mislabeled.
 It basically adds many new methods to the core classes which are
 useful but obviously not compatible in either way because if you go
 back you miss them and if you go forward they may clash with your own
 It also makes some core methods return Enumerator instead of Array
 which might break some code.

Home | Main Index | Thread Index | Old Index