pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/39763 (www/libgtkhtml has unstated dependency upon devel/gail)

The following reply was made to PR pkg/39763; it has been noted by GNATS.

From: Robert Elz <kre%munnari.OZ.AU@localhost>
Subject: Re: pkg/39763 (www/libgtkhtml has unstated dependency upon devel/gail) 
Date: Mon, 20 Oct 2008 19:15:21 +0700

     Date:        Mon, 20 Oct 2008 07:22:10 +0000 (UTC)
     Message-ID:  <>
   | Synopsis: www/libgtkhtml has unstated dependency upon devel/gail
   | Fixed libgtkhtml, please check.
 I will try later (I have some large builds in progress now, and don't
 want to remove the new gtk2+ (which avoids the problem) and replace it
 with the old one, in order to observe the libgtkhtml build fail...
 I think you can assume that if the dependency is correct, the problem
 is fixed, and close the PR.
   | Also, please report any others you stumbled over.
 The others I saw from my error log files (which by chance I still have
 lying around) from when I was building stuff with the old version of
 gtk2 around were ...
 graphics/eog           currently requires gtk2+>=2.8.0
 graphics/dia           which doesn't seem to care (in its Makefile.common)
                        which version of gtk2+ is installed, as long as
                        there is one - and so inherits the gtk2 buildlink
                        version dependeny I think (it said it needed >=2.6.0
                        but a the minute I don't see where that number
                        came from - of course, something else may have been
                        updated in the interim)
 games/gtetrinet                which inherits its dependency upon gtk2 from
                        graphics/libgnomecanvas which requires gtk2 >= 2.14.0
                        (though gtetrinet's build told me >= 2.6.0 - again).
                        libgnomecanvas has probably been updated more
                        recently than my attempted build of gtetrinet, so 
                        this one might have fixed itself already.
 All three of those had configure scripts that searched for gail and
 failed to find it (when gtk2 2.12.12 was installed, but not devel/gail)
 I will (I expect) never see this problem again, so I won't find other
 packages with similar problems, as I now have gtk2+ 2.14.3 installed &
 packaged, so gail will be there whenever gtk2 is now.

Home | Main Index | Thread Index | Old Index