pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39717: patch-ae in sysutils/gentoo uses mkdtemp

>Number:         39717
>Category:       pkg
>Synopsis:       patch-ae in sysutils/gentoo uses mkdtemp
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Oct 08 13:00:00 +0000 2008
>Originator:     Jörn Clausen
University of Bielefeld
SunOS spare4200 5.10 Generic_120012-14 i86pc i386 i86pc
patch-ae in sysutils/gentoo replaces tmpnam with mkdtemp. NetBSD's man-page of 
mkdtemp warns:

     The mkdtemp() function is nonstandard and should not be used
     if portability is required.

I think "portability" is a given for pkgsrc.
Compile under a OS that does not provide mkdtemp().
This should probably get fixed upstream and decided by configure. The function 
seems important enough to be added to other OSes:

Home | Main Index | Thread Index | Old Index