pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39708: converters/wv2 cannot locate suitable iconv (NetBSD 3.0) - probable libiconv buildlink problem

>Number:         39708
>Category:       pkg
>Synopsis:       converters/wv2 cannot locate suitable iconv (NetBSD 3.0) - 
>probable libiconv buildlink problem
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Oct 05 11:20:00 +0000 2008
>Originator:     Robert Elz
>Release:        NetBSD 4.0_STABLE   (pkgsrc current today).
        Prince of Songkla University
System: NetBSD 4.0_STABLE NetBSD 4.0_STABLE 
(JADE-1.696-20080517) #9: Fri May 23 18:55:13 ICT 2008 i386
Architecture: i386
Machine: i386
        converters/wv2 seems to need at least a relatively recent version
        of iconv (or libiconv or something in that area) - more recent
        than NetBSD 3.0 has in its base system.   yet it has no dependency
        upon the version in pkgsrc, which I am guessing would be recent
        enough (guessing without verification).

        This PR is serious/high as wv2 is required for koffice - otherwise
        I wounldn't care.

        Build converters/wv2 on a NetBSD 3.0 system (perhaps such a
        system with an empty /usr/pkg - or at least one without
        pkgsrc's iconv stuff installed - I don't know if having that
        just lying around would affect anything or not.)

        I use pkg_comp with libkver and NetBSD 3.0 release sets
        installed (and fairly regularly recreate an empty sandbox.)

        Expect to see ...

=> Bootstrap dependency digest>=20010302: found digest-20080510
=> Checksum SHA1 OK for wv2-0.2.3.tar.bz2
=> Checksum RMD160 OK for wv2-0.2.3.tar.bz2
===> Installing dependencies for wv2-0.2.3nb5
The following variables will affect the build process of this package,
wv2-0.2.3nb5.  Their current value is shown below:

        * FAM_DEFAULT = fam

Based on these variables, the following variables have been set:

        * FAMBASE (defined, but empty)
        * FAM_TYPE = fam

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Build dependency libtool-base>=1.5.18nb5: found libtool-base-1.5.24nb6
=> Build dependency pkg-config>=0.19: found pkg-config-0.23
=> Build dependency checkperms>=1.1: found checkperms-1.10
=> Full dependency libgsf>=1.14.7nb3: NOT found
=> Verifying bin-install for ../../devel/libgsf
===> Binary install for libgsf>=1.14.7nb3
=> Installing libgsf>=1.14.7nb3 from /pkg_comp/packages/All
libgsf-1.14.9 successfully installed.
=> Returning to build of wv2-0.2.3nb5

                [notice nothing about iconv in there at all]

===> Overriding tools for wv2-0.2.3nb5
===> Extracting for wv2-0.2.3nb5
===> Patching for wv2-0.2.3nb5
=> Applying pkgsrc patches for wv2-0.2.3nb5
===> Creating toolchain wrappers for wv2-0.2.3nb5
===> Configuring for wv2-0.2.3nb5
=> Modifying GNU configure scripts to avoid --recheck
=> Replacing config-guess with pkgsrc versions
=> Replacing config-sub with pkgsrc versions
=> Replacing install-sh with pkgsrc version
=> Fixing locale directory references.
INFO: [] Nothing changed in ./
INFO: [] Nothing changed in ./src/
INFO: [] Nothing changed in ./src/generator/
INFO: [] Nothing changed in ./tests/
=> Checking for portability problems in extracted files
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking build system type... i386-unknown-netbsdelf3.0
checking host system type... i386--netbsdelf
checking target system type... i386--netbsdelf
checking for i386--netbsdelf-gcc... cc
checking for C compiler default output file name... a.out

        [ and a whole bunch more normal looking configure noise ]

checking LIBGSF_CFLAGS... -I/usr/pkg/include/libgsf-1 
-I/usr/pkg/include/glib/glib-2.0 -I/usr/pkg/lib/glib-2.0/include 
checking LIBGSF_LIBS... -Wl,-R/usr/pkg/lib -L/usr/pkg/lib -lgsf-1 -lgobject-2.0 
-lxml2 -lglib-2.0 -lintl  
checking for iconv... yes
checking iconv.h usability... yes
checking iconv.h presence... yes
checking for iconv.h... yes
checking sys/iconv.h usability... no
checking sys/iconv.h presence... no
checking for sys/iconv.h... no
checking need for const in iconv... yes
checking whether the iconv installation is complete enough... no

wv2 depends on a modern iconv installation, supporting UNICODELITTLE and
UNICODEBIG. The detected iconv version doesn't support these conversions.

Please get a new libiconv from
You might want to install the library to some alternative directory, in
order not to overwrite your current installation. Please use the option
--with-libiconv=DIR to specify the location.

configure: error: * * * No iconv support - unable to continue * * *
*** Error code 1

make: stopped in /usr/pkgsrc/converters/wv2
WARNING: *** Please consider adding fortran to USE_LANGUAGES in the package 
*** Error code 1

        Now note that converters/wv2/Makefile includes ...

.include "../../converters/libiconv/"

        already, so pkgsrc's libiconv should be being pulled in (if
        needed bu the system) but isn't.


        Maybe (I am certainly guessing) wv2/Makefile needs an extra
        section like this one it already contains ...

# DragonFly's iconv(3) doesn't pass the configure check
.include "../../mk/"
.if ${OPSYS} == "DragonFly"
USE_GNU_ICONV=          yes

        except testing NetBSD_Version < whatever-is-appropriate

        That overall looks to be the wrong way to do it to me though,
        most likely DragonFly's iconv won't always be too old,
        and while old versions of NetBSD aren't going to change
        so could be tested for this way, it just seems the wrong place
        to do all this.

        It would seem better to me to pass in to libiconv/
        (via Make variable settings) the requirements this package places
        upon libiconv, and then allow the buildlink file to decide
        whether or not the base systems default iconv (if any) is
        good enough for the package in question's requirements, and
        if not, use the pkgsrc version.

        Someone who knows what they're doing can sort this out.

Home | Main Index | Thread Index | Old Index