pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/38988: Upgrade package to 9.05

The following reply was made to PR pkg/38988; it has been noted by GNATS.

From: "OBATA Akio" <>
Subject: Re: pkg/38988: Upgrade package to 9.05
Date: Sun, 10 Aug 2008 21:30:36 +0900

 On Thu, 19 Jun 2008 22:55:00 +0900, <> wrote:
 > This is just an upgrade to the latest stable version.
 > I never had issue with the previous one but the upgrade looked pretty 
 > straight forward.
 It seems not just an upgrade.
 There are some questions.
 1. All CONFIGURE_* are removed.
    Are those option useless in 9.05?
 2. USE_FEATURES+=snprintf also missing.
    Is it changed not to use snprintf?
 3. post-install target(installation of documentation, termcap and terminfo) is 
 4. perl option is still alive in, but in Makefile, fixed to use 
perl and
    PLIST is uncondifionally.
    9.05 can't build without perl, or useless, or just forgotten?
 5. wip/libev/ is commented out.
    9.05 should be used with libev package?
 6. patch-ab is missing (fixes CVE-2008-1142).
    9.05 is not contains it (Just mentioned in man, default display is :0).
    Really no need the patch? 

Home | Main Index | Thread Index | Old Index