pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39316: libgcrypt-1.4.1 fails to build with option "idea" enabled

>Number:         39316
>Category:       pkg
>Synopsis:       patch checksums not recorded and patches don't apply anyway
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Aug 07 23:10:00 +0000 2008
>Originator:     Christoph Badura
>Release:        NetBSD 3.1_STABLE
pkgsrc-2008Q2 from the evening of the branch tagging
System: NetBSD nervous-energy 3.1_STABLE NetBSD 3.1_STABLE (nervous-energy) #4: 
Fri Jul 25 06:31:02 MEST 2008 
root@nervous-energy:/src/sys/arch/i386/compile/nervous-energy i386
Architecture: i386
Machine: i386
===> Installing dependencies for libgcrypt-1.4.1
The supported build options for libgcrypt are:


The currently selected options are:


You can select which build options to use by setting PKG_DEFAULT_OPTIONS
or the following variable.  Its current value is shown:

        PKG_OPTIONS.libgcrypt = idea


===> Resuming update for libgcrypt-1.4.1
=> Bootstrap dependency digest>=20010302: found digest-20080510
=> Checksum SHA1 OK for libgcrypt-1.4.1.tar.gz
=> Checksum RMD160 OK for libgcrypt-1.4.1.tar.gz
checksum: No checksum recorded for libgcrypt-1.2.4-idea.diff.bz2
checksum: No checksum recorded for libgcrypt-1.2.4-idea.diff.bz2
ERROR: Make sure the Makefile and checksum file (/usr/pkgsrc/security/libgcrypt/
ERROR: are up to date.  If you want to override this check, type
ERROR: "/usr/bin/make NO_CHECKSUM=yes [other args]".
*** Error code 1

And after fixing the checksum with "make makesum" it fails with:

===> Patching for libgcrypt-1.4.1
=> Applying distribution patches for libgcrypt-1.4.1
1 out of 1 hunks failed--saving rejects to cipher/cipher.c.rej
1 out of 1 hunks failed--saving rejects to cipher/
1 out of 2 hunks failed--saving rejects to
1 out of 1 hunks failed--saving rejects to src/cipher.h.rej
1 out of 1 hunks failed--saving rejects to tests/basic.c.rej
ERROR: Patch libgcrypt-1.2.4-idea.diff.bz2 failed
ERROR: =========================================================================
ERROR: Some of the selected build options and/or local patches may be incompatib
ERROR: Please try building with fewer options or patches.
ERROR: =========================================================================
*** Error code 1

check out pkgsrc-2008Q2
echo "PKG_OPTIONS.libgcrypt=idea
ACCEPTABLE_LICENSES+=idea-license" >>/etc/mk.conf
cd security/libgcrypt && make


Home | Main Index | Thread Index | Old Index