pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Cannot bootstrap pkgsrc on AIX

pkgsrc-bugs@ is not for send directly.

Probably same as
 PR pkg/38397
 PR pkg/38450
 PR pkg/38221
on Solaris and IRIX.

Would you file this issue with send-pr?

On Sun, 29 Jun 2008 04:33:27 +0900, Jens Rehsack <> 

> Hi,
> I tried to bootstrap pkgsrc-2008Q1 on an powerpc-ibm-aix5.3.0.0 and it fails
> compiling/testing bmake.
> Because in former project we had problems with changing target locations
> (e.g. build into ~/project/bin and ~/project/lib and distribute it into
> /opt/project/...), we decided to build our required pkgsrc packages in a
> chroot, create an rpm from /opt/pkgsrc/ there and distribute it anywhere
> into /opt/pkgsrc.
> Now I chroot /opt/myroot/ and cd /opt/room/pkgsrc/bootstrap. Than I typed
> ./bootstrap and let it run. After a few minutes, the unit-test of bmake
> "freezes". I breaked it after a few hours and took a look into the makefiles
> there, removed the '@' and see, that the dotwait test fails after the simple
> test. Output at the end was:
> simple.1
> simple.1
> simple.2
> simple.2
> And that's all - nothing more.
> On the machine is an Visual Age C Compiler installed (but not used) and a
> gcc-4.2.0 (but the gcc3 we tried before had the same behaviour).
> Has anybody an idea or a hint, how we can go further?
> Best regards and thanks in advance,
> Jens

"Of course I love NetBSD":-)
OBATA Akio /

Home | Main Index | Thread Index | Old Index