pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Cannot bootstrap pkgsrc on AIX


I tried to bootstrap pkgsrc-2008Q1 on an powerpc-ibm-aix5.3.0.0 and it fails compiling/testing bmake.

Because in former project we had problems with changing target locations (e.g. build into ~/project/bin and ~/project/lib and distribute it into /opt/project/...), we decided to build our required pkgsrc packages in a chroot, create an rpm from /opt/pkgsrc/ there and distribute it anywhere into /opt/pkgsrc.

Now I chroot /opt/myroot/ and cd /opt/room/pkgsrc/bootstrap. Than I typed ./bootstrap and let it run. After a few minutes, the unit-test of bmake "freezes". I breaked it after a few hours and took a look into the makefiles there, removed the '@' and see, that the dotwait test fails after the simple test. Output at the end was:

And that's all - nothing more.

On the machine is an Visual Age C Compiler installed (but not used) and a gcc-4.2.0 (but the gcc3 we tried before had the same behaviour).
Has anybody an idea or a hint, how we can go further?

Best regards and thanks in advance,

Home | Main Index | Thread Index | Old Index