pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/38915: sysutils/gvfs compile problem in DragonFly

Matthias Drochner wrote:
> I suspect that Dragonfly's libarchive is not linked against
> libbz2 and libz implicitely. pkgsrc's version is.
> Has this been in an official D'fly release?


> If yes, we could either patch the gvfs configure script
> (and perhaps some more in the build system) to link
> against those libs explicitely, or force use of the
> pkgsrc libarchive, eg in libarchive/

I'd prefer second one. In this way version and flags are under control of 
pkgsrc. The version in DragonFly for example is older than the one in 
pksgrc. Btw, FreeBSD has also libarchive in the base and also seem to 
need -lbz2 and -lz:;content-type=text%2Fx-cvsweb-markup

Hasso Tepper

Home | Main Index | Thread Index | Old Index