pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/26013: Problem upgrading postfix

>Number:         26013
>Category:       pkg
>Synopsis:       Problem upgrading postfix
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jun 22 18:42:00 UTC 2004
>Originator:     Tim Jakobsen
>Release:        current
NetBSD emperor 1.6ZI NetBSD 1.6ZI (GENERIC) #10: Fri Jan 30 21:22:40 CET 2004  
root@cardinal:/usr/obj/sys/arch/i386/compile/GENERIC i386

After upgrading postfix ver. 2.0.20 to postfix ver. 2.1.3 using the pkgsrc tree 
all mail that postfix processes are marked as corrupt.

The problem arises because of the new queuemanager postfix uses. 
Upgrade postfix ver. 2.0.20 to postfix ver. 2.1.3 using the following command: 

cd /usr/pkgsrc/mail/postfix && /usr/bin/make update CLEANDEPENDS=yes

After that watch the maillog / mailqueues
To make sure postfix uses the new queuemanager make sure to stop the installed 
postfix before upgrading and remember to start the newly installed postfix 

Home | Main Index | Thread Index | Old Index