pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/25775: www/bkedit needs a modified xml2-config to link properly

>Number:         25775
>Category:       pkg
>Synopsis:       www/bkedit needs a modified xml2-config to link properly
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jun 01 14:39:00 UTC 2004
>Originator:     Cesar Catrian C.
>Release:        NetBSD 2.0_BETA i386

System: NetBSD 2.0_BETA (SAT) #0: Tue May 25 18:42:20 CLT 2004


www/bkedit can't be linked against libxml2.
===> Registering installation for bkedit-0.6.23
bkedit-0.6.23 requires installed package gtk+-1.2.10nb7
bkedit-0.6.23 requires installed package libxml2-2.6.9
/usr/pkg/bin/bkedit:     -lxml2.8 => not found
*** The above programs/libs will not find the listed shared libraries
    at runtime. Please fix the package (add -Wl,-R.../lib in the right places)!
*** Error code 1


make install at www/bkedit


The package can be installed with this patch to bin/xml2-config:

--- xml2-config.orig    2004-06-01 10:27:05.000000000 -0400
+++ xml2-config 2004-06-01 10:27:51.000000000 -0400
@@ -84,7 +84,7 @@
                echo -L${libdir} -lxml2 -lz   -lm  
-           echo -L${libdir} -lxml2 -lz   -lm  
+           echo -L${libdir} -Wl,-R${libdir} -lxml2 -lz   -lm  


Home | Main Index | Thread Index | Old Index