pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/24884: xfce4 needs to use CONF_FILES and PKG_SYSCONFDIR

>Number:         24884
>Category:       pkg
>Synopsis:       xfce4 needs to use CONF_FILES and PKG_SYSCONFDIR
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Tue Mar 23 02:07:00 UTC 2004
>Release:        NetBSD 1.6.2
System: NetBSD 1.6.1_STABLE NetBSD 1.6.1_STABLE (GENERIC) 
#0: Tue Aug 12 02:52:57 PDT 2003 i386
Architecture: i386
Machine: i386
I have xfce4-extras installed, but the configs are in non-standard
place on my system.

xfce4-desktop-4.0.4nb1, xfce4-panel-4.0.4nb1, xfce4-utils-4.0.4nb1
and maybe other xfce4 packages assume configuration
directory is ${LOCALBASE}/etc

It should use PKG_SYSCONFDIR.

(Another problem for me is etc/xfce4/xinitrc uses "which" which I don't
have on this particular system.)

Make sure xfce4 packages use PKG_SYSCONFDIR and CONF_FILES.

Home | Main Index | Thread Index | Old Index