Subject: Re: Some newbie questions and swearing
To: Jani Alanko <>
From: Richard Rauch <>
List: netbsd-users
Date: 04/12/2003 15:21:12

(A few points that I did not see covered by other respondants.  My
apologies if I'm repeating anything that you received in private
replies or which are in public posts that I haven't yet seen.  I read
this list via the web (see URL above), rather than subscribing.)

Did you sort out the problem with su?  The only time that I've ever
had a problem with it is when I'm not a member of "wheel".  You did
say that you put yourself in that group, but could you double-check?
Is it possible that you used some LINUXism that would put you in the
group?  Or did you just add your uid to the existing wheel group in
/etc/group?  (Might not hurt to logout/login after changing
/etc/group...)  If that doesn't work and you're still stuck, try
telling us exactly what you did to change your group, how you
created your regular user account, etc.

Re. changing consoles (unless/until you find out what's misconfigured
for su): X *remains* in graphic mode.  The problem that you have
encountered is a slightly baroque behavior of NetBSD, virtual consoles,
and X: The default NetBSD setup seems to be to have 5 virtual consoles,
but only 4 have attached ttys.  The 5th is "open".  When you run X in
that situation, X attaches to the open console (<ctr>-<alt>-<F5> to
get back to it after switching away), while the original console
*NEVER*LEFT* "text mode".  This is why you see text when you switch
back to the original console, as I understand the matter.  You don't
need to kill X to get back to a graphical session, you just need to
flip to the right virtual console.

Once all consoles are "occupied", starting a new X server from a text
console will use the same virtual console as you launched from.

(Another possiblity may be that virtual console #1 is reserved in text
mode for kernel messages.  If that's the case, the kernel may be forcing
X to use an "unallocated" console for graphics.  If you run "xconsole",
this isn't necessary, of course, but may be an intended "feature"
that I simply have not seen documented anywhere.)

About your soundcard, you don't say much other than to imply that it
doesn't work.  dmesg output might help, as might information about
what you've tried to do with it.  I have little problem playing sounds
on my systems.  But I've only ever been able to usably *record*
under NetBSD with my laptop.  (The only output problems that I've
had,  since sound support was added years ago, are with the Via
chipset in my Athlon tower.  Once in a great while (not since upgrading
to 1.6?), I've had it get "confused"; it sounded like, if memory serves,
it was using a double-buffered sound system and got the order of the
buffers reversed.  I haven't heard that happen in a long time, though.)
What do you do to try to use the soundcard?  Does it work at all, or
is it very quiet, or garbeled, or what?

Re. the TV card: I hope you find someone who can help.  I don't have
one (though I've occasionally thought about getting one).

Re. Mozilla mail and clipping text: This may be a Mozilla issue.  I
use mutt to read my mailbox in an xterm.  (^&  But I can certainly
cut-and-paste text in Mozilla's main webbrowser windows.  (I don't use
Mozilla mail, so I withhold comment---though it would be surprising
if you could cut-and-paste from one of Mozilla's text displays, but not

Your double-click problem could be a problem with the mouse.  Have you
tried different mice?  I don't think that I've ever had a mouse do that
to me, and because NetBSD translates mouse events into "wsmouse" protocol
events, it's hard to see it being caused by the X server bungling your
mouse protocol.  And it shouldn't be happening higher than that in the
X handling, because then other people would be seeing it.

When "it" exits at the end of the man-page, that's just the way that the
"more" program works.  Welcome to the world of "not just one OS".  (^&
It's a matter of taste.  According to man(1)'s page, the PAGER environment
variable lets you control the pager used.

If you don't like this behavior of man/more, you can do:
"setenv PAGER less" (or equivalent Bourne shell).  ("more" and
"less" are hardlinked to the same binary; apparently the binary
checks (at run-time) the name under which it was run and adapts

That covers the ponits that I didn't see mentioned in other replies.
Good luck.  And one small bit of advice: While you *should* be able to
get it set up identically to your old GNU/LINUX configuration, you
presumably wanted to experiment with something new.  Instead of proposing
to switch back because of some differences that you don't yet know how to
overcome, you might want to just tough it out and try adapting to a different
setup.  Again, good luck...and in any case, have fun.  (^&

  "I probably don't know what I'm talking about."