Subject: amanda and tape changers
To: None <>
From: Tim Rightnour <>
List: netbsd-users
Date: 08/18/1999 14:05:36
I'm having serious pain getting a tape changer working under amanda from

I try running amcheck -s DailySet1 and I get:

Amanda Tape Server Host Check
/amanda: 5690373 KB disk space available, that's plenty.
amcheck-server: could not get changer info: 10 1

(brought to you by Amanda 2.4.1p1)

While this is happening..  the changer picks up the tape in slot 0, and places
it in my drive.. the drive then starts doing something, and thats when
amcheck-server comes back failed..

I have an exabyte 10e changer, with an 8500 drive in it..  I have only two
tapes in the device right now.. so I tried setitng the device to only use two
tapes.. (the tapes are in slot 0 and 1)  I've also tried the conf file with all
slots enabled.. etc etc..

relevant portion of changer.conf below..

config          0
drivenum        0
dev             /dev/nrst0      # the device that is used for thetapedrive0
startuse        0       # The slots associated with the drive 0
enduse          1       # 
statfile        /usr/local/etc/amanda/tape5-slot  # The file where the actual sl
ot is stored
cleancart       -1      # the slot where the cleaningcartridge for drive 0 is
                        # located. -1 means none.
cleanfile       /usr/local/etc/amanda/tape0-clean # The file where the cleanings
 are recorded
usagecount      /usr/local/etc/amanda/backup/totaltime

Tim Rightnour <>
NetBSD: Free multi-architecture OS
NetBSD Mailing lists on the web: