NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/51524: USB vs. serial problems

>Number:         51524
>Category:       kern
>Synopsis:       USB vs. serial problems
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Oct 02 20:45:00 +0000 2016
>Originator:     Thomas Klausner
>Release:        NetBSD 7.99.39
Curiosity is the very basis of education and if you tell me that 
curiosity killed the cat, I say only that the cat died nobly.
- Arnold Edinborough
Architecture: x86_64
Machine: amd64
I wanted to look at the serial console of a second machine, so I
plugged in a USB serial dongle into my NetBSD (7.99.38/amd64):

ehci0 at pci0 dev 26 function 0: vendor 8086 product 1d2d (rev. 0x06)
ehci0: interrupting at ioapic0 pin 23
ehci0: BIOS has given up ownership
ehci0: EHCI version 1.0
usb0 at ehci0: USB revision 2.0
uhub2 at usb0: vendor 8086 EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhub5 at uhub2 port 1: vendor 8087 product 0024, class 9/0, rev 2.00/0.00, addr 2
uhub5: single transaction translator
uhub5: 6 ports with 6 removable, self powered
uftdi0 at uhub5 port 4
uftdi0: FTDI FT232R USB UART, rev 2.00/6.00, addr 4
ucom0 at uftdi0 portno 1

I set up 'minicom -s' to use /dev/dtyU0 and connected.  The screen
stayed empty, and the process was unkillable. I also tried 'cu -l
/dev/dtyU0' which had the same result.  (Even though there should
have been something visible on the serial line.)

At the same time, the USB keyboard and USB mouse stopped working,
without anything visible in dmesg.

I wanted other processes to finish before rebooting, so I waited.

4 hours later I saw the following in the kernel log:
ehci_sync_hc: cv_timedwait() = 35

4 hours later I tried rebooting, but had to press the reset button,
'shutdown -r' didn't work.

A couple days later I tried the same in single user mode to get
debugging output.
I had better luck, with 115200 baud I got some test patterns from the
device on the other end of the serial cable. I started and killed
cu a couple of times (3, perhaps 4?) and then the machine hung completely.
No reaction to USB keyboard nor PS/2 keyboard.

A couple other people reported having seen the same symptoms (see
current-users thread "USB serial problems" starting at
(and private emails).
See above.


Home | Main Index | Thread Index | Old Index