NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: kern/37924: can't reboot halt(8)ed system

The following reply was made to PR kern/37924; it has been noted by GNATS.

From: "Greg A. Woods; Planix, Inc." <>
To: David Holland <>
Subject: Re: kern/37924: can't reboot halt(8)ed system
Date: Sun, 13 Apr 2008 10:54:04 -0400

 On 12-Apr-08, at 10:41 PM, David Holland wrote:
 > On Wed, Jan 30, 2008 at 03:00:00PM +0000, 
 > wrote:
 >> After using e.g. shutdown to halt the system, rebooting by pressing
 >> any key does not work anymore. It used to work, but I don't remember
 >> when...
 > I can't replicate this on amd64 with today's -current. Are you still
 > seeing it?
 I've got what sounds like the same problem getting my i386 systems  
 using a serial console and running netbsd-4 to reboot after halt.  At  
 least one of them would reboot OK when running netbsd-1-6.  I tried  
 adding debugging to the code to no avail.  It's as if nothing is read  
 from the serial port in the loop where it's waiting for a key press to  
 I just tried rebooting one of them after booting a -current kernel and  
 running 'halt' and it worked fine.
 I'll try to do some diffs to see if I can spot some change that might  
 have some effect.
                                        Greg A. Woods; Planix, Inc.

Home | Main Index | Thread Index | Old Index