NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: misc/37731: vi and similar editors working bad

The following reply was made to PR misc/37731; it has been noted by GNATS.

From: Per Amund Amundsen <>
Subject: Re: misc/37731: vi and similar editors working bad
Date: Sat, 12 Jan 2008 14:31:25 +0100

 Try setting the enviroment variable LC_CTYPE (to no_NO.ISO8859-1 for 
 p.a. wrote:
 >> Number:         37731
 >> Category:       misc
 >> Synopsis:       vi and similar editors working bad
 >> Confidential:   no
 >> Severity:       serious
 >> Priority:       medium
 >> Responsible:    misc-bug-people
 >> State:          open
 >> Class:          support
 >> Submitter-Id:   net
 >> Arrival-Date:   Wed Jan 09 19:30:00 +0000 2008
 >> Originator:     Roberth Sjonøy
 >> Release:        4.0-RELEASE
 >> Organization:
 >> Environment:
 > Don't have any working enviroment, the problem isn't bound to one specific 
 > machine.
 >> Description:
 > I'm experiencing vi (and vim or elvis) to work weird on NetBSD, I'm using 
 > norwegian keyboard layout with norwegian keyboard, but vi acts like I have 
 > an english keyboard layout, not that characters like æ, ø and å isn't 
 > existing etc. but keys like tab are mized around on my keyboard, happens 
 > both outside and inside of an X-server enviroment.
 >> How-To-Repeat:
 > Install NetBSD 4.0-RELEASE i386 or amd64(these are the ports my computer can 
 > use), choose norwegian keyboard layout under the installation, and use a 
 > norwegian pc105 keyboard. Do simple editing with vi, vim or elvis, like 
 > entering insert mode etc.
 >> Fix:
 Per Amund Amundsen                    
 Department of Mathematics and Natural Science
 University of Stavanger                         Tlf: (+47) 51 83 18 77
 N-4036 Stavanger                                Fax: (+47) 51 83 17 50

Home | Main Index | Thread Index | Old Index