NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/37664: No audio output with recent auvia driver

>Number:         37664
>Category:       kern
>Synopsis:       No audio output with recent auvia driver
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jan 02 09:55:01 +0000 2008
>Originator:     Jari Kuittinen
>Release:        4.99.46
There's no audio signal coming out from the audio chip. Everything else seems 
to work perfectly, no complains from applications using the audio device etc. 
This affects both /dev/audio and /dev/sound

NetBSD <= 4.0 worked fine. The first version of -current I tried was from 

Playing around with audioctl had no effect (there's only one output port 

auvia0 at pci0 dev 17 function 5: VIA Technologies VT8237 AC'97 Audio (rev 0x60)
auvia0: interrupting at ioapic0 pin 22 (irq 10)
auvia0: ac97: Analog Devices AD1888 codec; headphone, 20 bit DAC, no 3D stereo
auvia0: ac97: ext id 3c7<AMAP,LDAC,SDAC,CDAC,SPDIF,DRA,VRA>
audio0 at auvia0: full duplex, mmap, independent
(pad0: outputs: 44100Hz, 16-bit, stereo)
(audio1 at pad0: half duplex)



Home | Main Index | Thread Index | Old Index