Subject: pkg/14509: apache-current overwrites libexpat.*
To: None <>
From: None <>
List: netbsd-bugs
Date: 11/09/2001 09:12:53
>Number:         14509
>Category:       pkg
>Synopsis:       apache-current overwrites libexpat.*
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Fri Nov 09 00:15:01 PST 2001
>Originator:     Martti Kuparinen
>Release:        NetBSD 1.5.2
System: NetBSD dhcp118 1.5.2 NetBSD 1.5.2 (KAYAK) #0: Wed Oct 3 11:34:19 PDT 2001 root@dhcp118:/usr/src/sys/arch/i386/compile/KAYAK i386


apache-current has the following problems:

2) This package installs libexpat.* files into ${PREFIX}/lib. If the
   system already has expat-[0-9]* installed this will destroy/overwrite it.



  This means we have to update patches/patch-ae so that the problematic
  configuration section is commented out. A simple thing to do.

2) We have two alternatives: make apache-current CONFLICT with expat-[0-9]*
   or patch apache's files to use the already-installed expat package (I
   think this is better).

Unfortunately I don't have time right now to fix this so I thought it's
better to file a PR so that this will not be forgotten...