tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: draft mcount(3) man page

On Sat, 22 May 2021, David Holland wrote:

To cut down on future confusion we should probably (if it's not
excessively expensive for some reason) change all the compiler configs
to call "__mcount_hook" and change the name of the C function to
always be "__mcount_impl" or "__mcount_backend" or something like
that. Having both _mcount and __mcount is terrible, especially when
their roles are exchanged on ~half the ports we have.

Yeah, this really is begging for a clean-up.

| Paul Goyette       | PGP Key fingerprint:     | E-mail addresses:     |
| (Retired)          | FA29 0E3B 35AF E8AE 6651 |     |
| Software Developer | 0786 F758 55DE 53BA 7731 |   |

Home | Main Index | Thread Index | Old Index