Subject: Re: Fwd: devel/pcre fails...
To: None <>
From: George Georgalis <>
List: tech-pkg
Date: 10/27/2006 20:24:59
On Fri, Oct 27, 2006 at 09:18:23AM -0700, Tom Spindler wrote:
>It would help if you pasted the libtool line as well; FYI, my system
>rm -f
>/bin/sh ./libtool --mode=link --tag=CC cc -export-symbols-regex '^[^_]' -Wl,-R/usr/pkg/lib -I. -I. -rpath /usr/pkg/lib -version-info  '0:1:0' -o pcre_chartables.lo  pcre_compile.lo  pcre_config.lo  pcre_dfa_exec.lo  pcre_exec.lo  pcre_fullinfo.lo  pcre_get.lo  pcre_globals.lo  pcre_info.lo  pcre_maketables.lo  pcre_ord2utf8.lo  pcre_refcount.lo  pcre_study.lo  pcre_tables.lo  pcre_try_flipped.lo  pcre_ucp_searchfuncs.lo  pcre_valid_utf8.lo  pcre_version.lo  pcre_xclass.lo
>generating symbol list for `'
>nm  .libs/pcre_chartables.o .libs/pcre_compile.o .libs/pcre_config.o .libs/pcre_dfa_exec.o .libs/pcre_exec.o .libs/pcre_fullinfo.o .libs/pcre_get.o .libs/pcre_globals.o .libs/pcre_info.o .libs/pcre_maketables.o .libs/pcre_ord2utf8.o .libs/pcre_refcount.o .libs/pcre_study.o .libs/pcre_tables.o .libs/pcre_try_flipped.o .libs/pcre_ucp_searchfuncs.o .libs/pcre_valid_utf8.o .libs/pcre_version.o .libs/pcre_xclass.o  | sed -n -e 's/^.*[       ]\([ABCDGIRSTW][ABCDGIRSTW]*\)[         ][      ]*\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2 \2/p' | /usr/bin/sed 's/.* //' | sort | uniq > .libs/libpcre.exp
>And so the missing command between "|  |" is a big awful sed expression.

I re-posted when I got the same error again with 2006Q3.  Today
when I tried to repeat for the libtool line requested, the
Makefile was gone (normal result of bmake failure, at least a few
tags ago), I just moved pcre away completely and did "cvs -q upd
-dP" and it worked!!  That is a SUPER fix, whatever happened...

But the last change to pcre was over 3 weeks ago and I had already
done a cvs update.  I thought "cvs -q upd -dP" would have been

// George

George Georgalis, systems architect, administrator <IXOYE><