tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: PCN0 problem

On Sat, 26 Jun 2021 21:42:48 -0000 (UTC), T wrote:

> Hello,
> I have a problem with the pcn0 NIC on the following machine:
> The integrated pcn0
> causes the machine to become unresponsive if interacting with it through
> NetBSD. Two specific examples I can think of are:
> 1) When I originally obtained the system, I used the firmware net boot
> functionality to load the sysinst image over the network and tried to
> install packages from a NFS share. This would initiate and load into
> sysinst, but then the system would become completely unresponsive during
> the unpacking phase of the install, as in the screen would become frozen
> on output related to unpacking the sets. Pressing the NUM_lock key would
> not toggle the keyboard LED for it and no user interaction seemed to
> work (remote ping, SSH, keyboard, debugger key sequence). I started
> using NetBSD with this machine with one of the later version 7 releases,
> from which this example originates.
> 2) Currently, with 9.2_STABLE, I can reproduce this problem by just
> calling 'dhcpcd pcn0', which will cause the same unresponsive behavior
> as mentioned above. I have worked around this issue by using an
> alternative add-on NIC, but interacting with the integrated pcn NIC has
> always been an issue since the original example.
> The system firmware does not seem to have any problems with the NIC when
> using built-in device tests or net boot functionality.
> I was wondering if anyone else has had issues with this driver (likely
> being used on a different port) and if the problem is likely not a
> driver issue, but specific to port-prep? It has been mentioned to me on
> IRC that I might need to use something like KGDB to troubleshoot the
> issue, but that would need to be added to the port, because it does not
> currently exist.

I did some additional testing using the firmware net boot functionality 
to test sysinst.fs images for 6.2, 7.0, 7.1, 7.2, 8.0, 8.1, and 8.2 . 
These all appeared to work fine when using the installer "configure 
network" utility menu option and ping utility. The 9.0 sysinst.fs is too 
large to work on this system so I had to switch over to the smaller 
sysinst_small.fs image. This version did not work like the others, and 
had a noticeable problem with the "configure network" option in the 
utility menu. Attempting to select a NIC "media" would not accept values. 
In prior versions, this had a populated default of (autoconfigure), but 
was missing for 9.0 . Trying the sysinst_small.fs image for 8.2 worked 
fine and appeared to function the same as the regular sysinst.fs image.

Home | Main Index | Thread Index | Old Index