tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: About bridges

Mouse wrote:
I then thought that a solution would be to put the IP address on some
pseudo-device also attached to the bridge, but could not find something

Perhaps some way to configure a tap device so that it works for these


It wasn't necsessary, tap did just work as a virtual interface.

So given these hints, tap IS supposed to work as a virtual ethernet interface.

I tried setting this up on my laptop running 9.0_STABLE from Sep 2 2020
(the apu is slated to be installed today so I don't want to do more fiddling
with it) with this config:

interface wm0 up no other config
interface tap0 -"-

brconfig bridge0 add wm0 stp wm0 add tun0

I deliberately did not have dhcpcd running.

After bridge had pondered the stp situation the wm0 interface got to
forwarding, and everything seemed ok.

However as I ran dhcpcd -1 tap0, only ipv6 was configured on the tap interface.

With some judicious tcpdumping I could see that the dhcp requests were leaving
tap0, passing through the bridge and leaving on the wm0 to arrive on the dhcp
server, the replies however left the dhcp server with the right mac, arrived
on the wm0 but never made it to the tap0 device.

If I manually configure tap0 to have an ipv4 address, it responds to ping, but
no icmp packets are seen in the tcpdump (wtf). It also works to talk TCP (I
tried ssh), but no packets from that again visible in the dump on tap0.

If i just dump everything on tap0 I can see some lldp packets the mikrotik
ap/switch it is plugged into sends, various (v4) multicast noise and lots of
ipv6 ndp and ra packets (as expected)

What am I missing now? DHCP replies seem to go missing alltogether and some
ipv4 packets aren't shown in tcpdump on the tap interface.

ipv6 on the other hand, works magically.

This was presumably why I thought tap didn't work as a host interface when I
was fiddling with the apu.


Home | Main Index | Thread Index | Old Index