tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: -current kernel + -7 userland + carp + ipf = failure

In article <>,
Stephen Borrill  <> wrote:
>I'm continuing trying to get carp(4) + default gateway working as 
>described in:
>I was trying to test whether carp(4) worked any better in -current, so 
>built a -current XEN3_DOMU kernel with carp added.
>Firstly, I noticed that I had no network access at all. carp had 
>successfully negotiated MASTER and BACKUP statuses on the hosts, but I 
>could not ping anything:
>xennet0: flags=8963<MULTICAST> mtu 1500
> 	capabilities=2800<TCP4CSUM_Tx,UDP4CSUM_Tx>
> 	enabled=0
> 	ec_capabilities=1<VLAN_MTU>
> 	ec_enabled=0
> 	address: d6:41:19:58:cc:d5
> 	inet6 fe80::d441:19ff:fe58:ccd5%xennet0 prefixlen 64 scopeid 0x2
> 	capabilities=2800<TCP4CSUM_Tx,UDP4CSUM_Tx>
> 	enabled=0
> 	carp: MASTER carpdev xennet0 vhid 1 advbase 1 advskew 0
> 	address: 00:00:5e:00:01:01
> 	inet netmask 0xffffff00 broadcast
>If I configure an IP address directly on xennet0 it works.
>Secondly, I ran ipf -D and got the following:

I just fixed that one, thanks!


Home | Main Index | Thread Index | Old Index