tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

ad-hoc to JoikuSpot

        JoikuSpot is software which lets a Symbian S60 3rd Edition
        share its internet connection via ad-hoc Wi-Fi.


        I can happily connect via a WindowsXP box, but I'm not
        having any luck connecting via a NetBSD (This is the first
        time I've tried using ad-hoc 802.11 networking, so its
        quite possible I'm missing something basic).

        I've tried on two NetBSD 4.0/i386 boxes, one with a wpi and
        the other an ath wireless chipset.

# wlanctl -a reports:
wpi0: mac 00:1a:89:f3:7b:62 bss aa:c1:e7:7f:b2:16
        node flags 0004<scan>
        ess <abs-e90>
        chan 1 freq 2412MHz flags 04e0<cck,ofdm,2.4GHz,dynamic cck-ofdm>
        capabilities 0022<ibss,short preamble>
        beacon-interval 100 TU tsft 24273818250 us
        rates *1.0 *2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 [54.0]
        assoc-id 0 assoc-failed 0 inactivity 300s
        rssi 31 txseq 0 rxseq 0

# ifconfig wpi0 ssid abs-e90 bssid aa:c1:e7:7f:b2:16

# ifconfig wpi0 wpi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        ssid abs-e90
        powersave off
        bssid aa:c1:e7:7f:b2:16
        address: 00:19:d2:77:72:d9
        media: IEEE802.11 autoselect (DS1)
        status: no network
        inet netmask 0xff000000 broadcast

        Adding 'chan 1' to the initial ifconfig line doesn't seem
        to affect matters

        Anyone have any thoughts as to what I'm missing?


Home | Main Index | Thread Index | Old Index