tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Old thread: Re: Allowing large PPPoE frames

On Thu, Apr 17, 2008 at 01:31:27AM +0200, Martin Husemann wrote:
> On Wed, Apr 16, 2008 at 11:18:47PM +1000, Paul Ripke wrote:
> > Hmm. Couldn't get past:
> >   ifconfig: SIOCSIFMTU: Invalid argument
> > no matter what I tried. Reading the code, it should be possible.
> I think you need to enlarge the mtu on the ethernet device before
> assigning it to pppoe via pppoectl -e. The pppoe device then should pick
> up the right mtu for itself automatically.

Yeah, I had about 6 goes. Roughly, my "best attempt" steps were:

ifconfig sk0 mtu 1560
ifconfig pppoe0 down destroy
ifconfig pppoe0 create debug
pppoectl -e sk0 pppoe0
pppoectl pppoe0 myauthproto=...
ifconfig pppoe0 inet mtu 1500
ifconfig pppoe0 up

At the end, the interface MTU was 1492, and the MRU in the
negotiation was 1492. I'm pretty sure I tried without the
"mtu 1500" above, and it still ended up with 1492.

If I just tried:

ifconfig sk0 mtu 1560
ifconfig pppoe0 down debug
ifconfig pppoe0 mtu 1500

... and I'd get SIOCSIFMTU returning EINVAL.

Am I missing something?

Paul Ripke

Home | Main Index | Thread Index | Old Index