Subject: Re: 'wiconfig -D' failing with ioctl: Operation now in progress
To: Liam J. Foy <>
From: David Brownlee <>
List: tech-net
Date: 12/30/2006 23:25:08
On Sat, 30 Dec 2006, Liam J. Foy wrote:

> On 30 Dec 2006, at 21:05, David Young wrote:
>> On Sat, Dec 30, 2006 at 08:38:06PM +0000, David Brownlee wrote:
>>> 	Since updating to NetBSD 4.0_BETA2 (from NetBSD 3) I've
>>> 	been unable to get wiconfig -D to work. I've tried with
>>> 	ath0, rtw0, and iwi0 on two different machines.
>>> 	In all cases the ioctl() SIOCGWAVELAN loop times out without
>>> 	getting any result.
>>> 	Increasing retries from 10 to 60 (sec) did not affect the result.
>>> 	Is there anything I should be looking at to try to track this
>>> 	down?
>> David,
>> Did it work with ath, rtw, and iwi on NetBSD 3?  I did not think it did.
>> I only expect for it to work with wi.  Everything other driver is
>> a toss-up.

 	It worked fine with ath on NetBSD 3. It would fail maybe one
 	time in a hundred or less.

>> I have been saying so for some time, but here we go again: NetBSD *really*
>> needs to borrow the 'list scan' functions from ifconfig in FreeBSD.
>> All of the kernel support should be in NetBSD already.  Borrowing those
>> functions does not require any 802.11 expertise.  Don't wait for me to
>> do it, I haven't the time or the interest.
> I spoke to Sam regarding this and produced a patch set (based on
> FreeBSD, of course). However, I am unable to do anything with the code
> since I don't have a supported card according to Sam, so I just left it.
> Not too sure where the code is now, but it didn't take long to fix up.

 	If you might have the time and interest to look at this again,
 	what would it take to get a supported card to you - I'd be
 	happy to (within reason) order one online and ship to you.

 		David/absolute       -- No hype required --