Subject: Re: cellphone modem troubles
To: Ignatios Souvatzis <>
From: Matthias Ferdinand <>
List: tech-net
Date: 12/27/2006 00:27:53
--On Dienstag, Dezember 26, 2006 22:24:37 +0100 Ignatios Souvatzis 
<> wrote:
> None of this is relevant - if the kernel signals EOF to the userland pppd,
> you can't help by ignoring it. Maybe the answer to the 3rd question below
> will tell us why it thinks it should do that.


no, I did not intend to use that hack for production :-) Just to prove that 
the modem does not mean to hangup but actually is still delivering data.

> 1st question: do you run pppd as root? If not, please do.
yes, I called it as root. Logged in as adminmf, then su, then pppd. Same 
when logging in directly as root

> 2nd question: is the Siemens phone connected by an USB cable or by an
> RS232 cable? (Some USB-RS232 dongles have carrier detection
it's an RS232 cable. Sorry for not telling straight away. dmesg excercpt:
  isa0 at pcib0
  lpt0 at isa0 port 0x378-0x37b irq 7
  com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
  com2 at isa0 port 0x3e8-0x3ef irq 5: ns16550a, working fifo

> are RS232 over USB in disguise. In this case, a netbsd-4 beta2 kernel
> should help.)
I tried with netbsd-3 (3.1) kernel, same result. I will try netbsd-4 next.

Although the issue is probably not the phones, there might still be some 
hardware issue in the notebook itself, even though it works with the 
standard voice modem. Last time I used that under Linux was about a year 
ago, and at the moment I cannot afford to temporarily reinstall just for 
checking. Although it lists com0 and com2, there is only one rs232 
connector. The other one is presumably an ir adapter, but that does not 
seem to connect to the phones ir.

> 3rd question: can yo please increase the "debug" count to pppd, and show
> us pppd's debug output?
It was already running with 4 "debug"s. As the hangup is signalled 
immediately after "Serial connection established", pppd does not get a 
chance to do any negotiations. Only my hacked pppd that ignored the hangup 
could see some LCP packets from remote.

kern,daemon,local2.*                                    /var/log/ppp-log

with kdebug 7, 4x debug:
Dec 27 00:05:36 shlab chat[565]: PPP session from (<ip1>) to <ip2> 
Dec 27 00:05:36 shlab chat[565]:  -- got it
Dec 27 00:05:36 shlab pppd[563]: Serial connection established.
Dec 27 00:05:36 shlab pppd[563]: Using interface ppp0
Dec 27 00:05:36 shlab pppd[563]: Connect: ppp0 <--> /dev/tty00
Dec 27 00:05:36 shlab pppd[563]: Modem hangup
Dec 27 00:05:36 shlab pppd[563]: Connection terminated.
Dec 27 00:05:36 shlab /netbsd: ppp0: bad protocol 206
Dec 27 00:05:38 shlab pppd[563]: Exit.

Thank you.

Best regards