Subject: Re: Netatalk and rtk drivers
To: Adam Lebsack <>
From: Bill Studenmund <>
List: tech-net
Date: 07/30/2002 19:31:43
On Sun, 28 Jul 2002, Adam Lebsack wrote:

> Perhaps someone has some advice for my problem:
> I have a Realtek NIC in my macppc netbsd 1.6 box:
> rtk0 at pci0 dev 15 function 0: RealTek 8139 10/100BaseTX
> rtk0: interrupting at irq 25
> rtk0: Ethernet address 00:20:18:d9:fa:54
> ukphy0 at rtk0 phy 7: Generic IEEE 802.3u media interface
> ukphy0: OUI 0x000000, model 0x0000, rev. 0
> ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
> Another machine on my LAN runs a netatalk router, and every machine is
> able to bind to the appletalk zone which I have setup, except for this
> macppc box with the realtek card. Netatalk is a builtin option in the
> kernel as well. I tried a 10baseT nic, and it works just fine on that
> box.  I also tried using the card in an i386 machine with netbsd and
> linux, with the same results.
> I know this card is capable of working with appletalk networks, because
> the Windows driver for the card and PC Maclan together allow it to bind
> to the zone.
> This leads me to believe that the NetBSD and linux drivers for the card
> are not working properly, making the card unable with communicate
> properly with the DDP protocol.
> Has anyone else seen this behavior, or does anyone know where I could
> start with the rtk driver in isolating/fixing the problem?

I haven't seen that behavior, though my experience with thos cards is that
they weren't very good. I think you'd be much better off if you got a
different card. Around here, NetGear FA 311 cards are about $20, and work
great (don't get the 310, there is a reason the 311 is out).

Take care,