Subject: Netatalk and rtk drivers
To: None <>
From: Adam Lebsack <>
List: tech-net
Date: 07/28/2002 12:37:08
Perhaps someone has some advice for my problem:

I have a Realtek NIC in my macppc netbsd 1.6 box:
rtk0 at pci0 dev 15 function 0: RealTek 8139 10/100BaseTX
rtk0: interrupting at irq 25
rtk0: Ethernet address 00:20:18:d9:fa:54
ukphy0 at rtk0 phy 7: Generic IEEE 802.3u media interface
ukphy0: OUI 0x000000, model 0x0000, rev. 0
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

Another machine on my LAN runs a netatalk router, and every machine is 
able to bind to the appletalk zone which I have setup, except for this 
macppc box with the realtek card. Netatalk is a builtin option in the 
kernel as well. I tried a 10baseT nic, and it works just fine on that 
box.  I also tried using the card in an i386 machine with netbsd and 
linux, with the same results.

I know this card is capable of working with appletalk networks, because 
the Windows driver for the card and PC Maclan together allow it to bind 
to the zone.

This leads me to believe that the NetBSD and linux drivers for the card 
are not working properly, making the card unable with communicate 
properly with the DDP protocol.

Has anyone else seen this behavior, or does anyone know where I could 
start with the rtk driver in isolating/fixing the problem?

ifconfig rtk0:
         address: 00:20:18:d9:fa:54
         media: Ethernet autoselect (100baseTX full-duplex)
         status: active
         inet netmask 0xffffff00 broadcast
         atalk 65280.28 range 1-65534 phase 2 broadcast 65280.28

ifconfig le0: (sparc appletalk router)
         address: 08:00:20:81:39:68
         media: Ethernet 10baseT
         status: active
         inet netmask 0xffffff00 broadcast
         atalk 10.1 range 10-10 phase 2 broadcast 10.1

Thanks, and if there is any other info I can provide, just ask.  :)