Subject: Re: Strange mountd and NFS export behavior, NetBSD/i386 1.5.
To: Brian Chase <>
From: Manuel Bouyer <>
List: tech-net
Date: 02/07/2001 10:07:52
On Tue, Feb 06, 2001 at 03:54:35PM -0500, Brian Chase wrote:
> I tried stoping and restarting mountd, in addition to initially shutting
> down mountd, nfsd, and then rpcbind.  That was before I realized that it
> was just a problem with mountd and not the NFS subsystem in general.
> Other systems which already had home mounted were fine.
> I tried running mountd with the -d option, but that really didn't give any
> useful info.  The output was extremely terse.
> FWIW, the server's filesystem (oreo:/home) is a large LFS filesystem
> (~60GB). Earlier this morning I rebooted the system.  This cleared the
> problem.  I think there may be something funny going on between LFS (maybe

Ho, don't NFS-export an LFS filesystem ! This won't work for now.
The cleaner things in the back of the NFS daemon, which confuses it.
You can eventually corrupt your filesystem this way.

Manuel Bouyer, LIP6, Universite Paris VI.