Subject: Re: Strange mountd and NFS export behavior, NetBSD/i386 1.5.
To: Manuel Bouyer <>
From: Brian Chase <>
List: tech-net
Date: 02/06/2001 15:54:35
On Tue, 6 Feb 2001, Manuel Bouyer wrote:
> On Mon, Feb 05, 2001 at 05:06:09PM -0500, Brian Chase wrote:

> > My mountd daemon has all of a sudden decided to start spewing forth the
> > following errors into /var/log/messages:
> >
> >   Feb  5 16:49:42 oreo mountd[12509]: "/home", line 1: Can't change
> >     attributes for /home to Default
> >
> > The only line I have in my /etc/exports file is
> >
> >   /home
> Did you try to kill and restart mountd ?
> Has the /home filesystem moved in some way ?

I tried stoping and restarting mountd, in addition to initially shutting
down mountd, nfsd, and then rpcbind.  That was before I realized that it
was just a problem with mountd and not the NFS subsystem in general.
Other systems which already had home mounted were fine.

I tried running mountd with the -d option, but that really didn't give any
useful info.  The output was extremely terse.

FWIW, the server's filesystem (oreo:/home) is a large LFS filesystem
(~60GB). Earlier this morning I rebooted the system.  This cleared the
problem.  I think there may be something funny going on between LFS (maybe
the lfs_cleanerd?) and mountd.  I'll keep an eye on it in case this
happens again, but given that the reboot cleared it, something weird is
very likely going on here.

--- Brian Chase | | -----
    My subconscious is a whirling sea of glowing lutefisk.  -- K.