Subject: Re: getnameinfo type incompatibility
To: None <>
From: None <>
List: tech-net
Date: 05/06/2000 01:15:00
> > 	KAME codebase made a mistake about 2nd argument type of getnameinfo
> > 	(rfc2553 uses socklen_t.  KAME uses size_t based on pre-2553 document).
> > 	does the following patch look reasonable?  if you have better name for
> > 	__RENAME() hack please let me know.
> > 	really sorry for this, we should have noticed it earlier...
>Um... I think on all the architectures we support, this is not an ABI
>change, so you don't have to rename the function.  You can just change
>the argument of the current one.
>i.e. the unsigned int (socklen_t) is getting promoted to register size
>anyhow on register-based platforms, and all of the LP64 platforms pass
>arguments in this way...

	Thanks, I'm really happy to hear this.  If I don't hear anyone scream
	I'm going to rename 2nd arg type.