Subject: Re: getnameinfo type incompatibility
To: None <>
From: Jason R Thorpe <>
List: tech-net
Date: 05/05/2000 09:07:53
On Sat, May 06, 2000 at 12:56:49AM +0900, wrote:

 > 	KAME codebase made a mistake about 2nd argument type of getnameinfo
 > 	(rfc2553 uses socklen_t.  KAME uses size_t based on pre-2553 document).
 > 	does the following patch look reasonable?  if you have better name for
 > 	__RENAME() hack please let me know.
 > 	really sorry for this, we should have noticed it earlier...

Um... I think on all the architectures we support, this is not an ABI
change, so you don't have to rename the function.  You can just change
the argument of the current one.

i.e. the unsigned int (socklen_t) is getting promoted to register size
anyhow on register-based platforms, and all of the LP64 platforms pass
arguments in this way...

        -- Jason R. Thorpe <>