tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: fs-independent quotas

At 15:14 Uhr +0200 21.10.2011, Manuel Bouyer wrote:
>> This is bound to cause tremendous confusion.  Can we please change the name
>> to "fs_quota_entry"?  Consider what will happen when (or if) there is a
>> "zfs_quota_entry" or an "lfs_quota_entry": it will look to anyone reading
>> the code as if ufs_quota_entry is specific to the ufs layer and the
>> filesystems that use it.  Not good.
>ufs_quota_entry is part of the API now,

... not in a formal release.

> and at last netatalk started using it.

In a release that is pretty wobbly; afaik the 2.2.1 package doesn't work.

I'd second that the ufs prefix is not what you want here.


"It's never straight up and down"     (DEVO)

Home | Main Index | Thread Index | Old Index