tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: PCMCIA broken (was Re: no ndis* at cardbus?)

On Wed, 11 Feb 2009 19:48:12 +0100
Matthias Drochner <> wrote:

> As said, CompactFlash works for me. Seems I'm just lucky.
> said:
> >     RBUS_IO_BASE = 0x4000   # default, does not work
> >     RBUS_IO_BASE = 0x0a00   # works. 
> Perhaps there is some problem with incomplete decoding?
> The i386 CARDBUS config file suggests 0x600 btw.
> > at least one 32-bit card that I have
> > (a USB2.0 card I think with VIA chips) caused a panic on insertion
> > but I didn't write the reason down[3]
> most likely an address conflict with something allocated
> by the BIOS, leading to all kinds of weird symptoms
> > [3] I haven't worked out how to make the message buffer persist
> > through a reboot on this machine yet 

I've tried a CF card via an adapter in a PCMCIA slot.  It's never
worked on my amd64 laptop (T61), running -current from about 15 months
until now -- it finds the controller but not the disk.  It had been
working on a T42, but this morning it found the disk bout couldn't read
from it.  (This is running 5.99.6.)

                --Steve Bellovin,

Home | Main Index | Thread Index | Old Index