Source-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

CVS commit: src/sys/arch



Module Name:    src
Committed By:   maxv
Date:           Thu Mar  7 14:40:35 UTC 2019

Modified Files:
        src/sys/arch/amd64/include: pte.h
        src/sys/arch/i386/include: pte.h

Log Message:
Introduce a new set of PTE bits, with a different naming convention.

        PG_V      -> PTE_P        /* Present */
        PG_RW     -> PTE_W        /* Write */
        PG_u      -> PTE_U        /* User */
        PG_WT     -> PTE_PWT      /* Write-Through */
        PG_N      -> PTE_PCD      /* Cache-Disable */
        PG_U      -> PTE_A        /* Accessed */
        PG_M      -> PTE_D        /* Dirty */
        PG_PAT    -> PTE_PAT      /* PAT on 4KB Pages */
        PG_PS     -> PTE_PS       /* Large Page Size */
        PG_G      -> PTE_G        /* Global Translation */
        PG_AVAIL1 -> PTE_AVL1     /* Ignored by Hardware */
        PG_AVAIL2 -> PTE_AVL2     /* Ignored by Hardware */
        PG_AVAIL3 -> PTE_AVL3     /* Ignored by Hardware */
        PG_LGPAT  -> PTE_LGPAT    /* PAT on Large Pages */
        PG_NX     -> PTE_NX       /* No Execute */

Until now we were using "PG_BIT". The "BIT" part of the naming did not
follow the x86 naming convention in the spec, and was very confusing. We
don't want the "PG_" part of it either, because UVM has similar flags
(ie PG_BUSY).


To generate a diff of this commit:
cvs rdiff -u -r1.10 -r1.11 src/sys/arch/amd64/include/pte.h
cvs rdiff -u -r1.29 -r1.30 src/sys/arch/i386/include/pte.h

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.




Home | Main Index | Thread Index | Old Index