Source-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

CVS commit: src/external/bsd/mdocml/dist

Module Name:    src
Committed By:   christos
Date:           Sat Nov 24 22:29:09 UTC 2012

Modified Files:
        src/external/bsd/mdocml/dist: tbl_data.c

Log Message:
XXX: rename data() to getdata(). This is to avoid an assembler botch on the
ppc64 toolchain where function names are prefixed with a period, so "data"
becomes ".data" and ".data" is confused by the assembler with the segment
directive with the same name. Clearly this is a toolchain issue; we should
be able to call functions "text" and "data" but it is simpler to fix the
code rather than the toolchain.

To generate a diff of this commit:
cvs rdiff -u -r1.3 -r1.4 src/external/bsd/mdocml/dist/tbl_data.c

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.

Home | Main Index | Thread Index | Old Index