Source-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

CVS commit: src/sys/dev/raidframe



Module Name:    src
Committed By:   oster
Date:           Mon Dec 29 05:22:16 UTC 2003

Modified Files:
        src/sys/dev/raidframe: rf_debugMem.c rf_diskqueue.c rf_driver.c
            rf_engine.c rf_paritylogging.c rf_threadstuff.c rf_threadstuff.h

Log Message:
_rf_create_managed_mutex() is doing just a simple:

 rf_mutex_init(m)

now.  The rest of the fluff is no longer needed.
It also cannot fail, so error checking on rf_create_managed_mutex()
is just wasting space.

Nuke the #define's associated with rf_create_managed_mutex().
Convert rf_create_managed_mutex(listp,m) to just rf_mutex_init(m).
Remove wasteful "error checking" and simplify all instances where this
is called.  (another 0.3K saved in the binary, but the real savings
is in code readability!)


To generate a diff of this commit:
cvs rdiff -r1.12 -r1.13 src/sys/dev/raidframe/rf_debugMem.c
cvs rdiff -r1.24 -r1.25 src/sys/dev/raidframe/rf_diskqueue.c
cvs rdiff -r1.74 -r1.75 src/sys/dev/raidframe/rf_driver.c
cvs rdiff -r1.25 -r1.26 src/sys/dev/raidframe/rf_engine.c
cvs rdiff -r1.18 -r1.19 src/sys/dev/raidframe/rf_paritylogging.c
cvs rdiff -r1.15 -r1.16 src/sys/dev/raidframe/rf_threadstuff.c \
    src/sys/dev/raidframe/rf_threadstuff.h

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.




Home | Main Index | Thread Index | Old Index