Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Issues with compiler failures

On 2019-03-21 01:04, Paul Koning wrote:

On Mar 20, 2019, at 5:44 PM, Johnny Billquist <bqt%update.uu.se@localhost> wrote:

On 2019-03-17 11:16, Johnny Billquist wrote:
On 2019-03-17 11:05, maya%netbsd.org@localhost wrote:
Or you can use -O0 whenever this happens and not lose anything.
Ok. I'll run through some build stuff on VAX and report the current status...

Downloaded current, and started a native build.

It comes as far as tools/gcc in the build before it fails. This is a new error I've not seen before. Maybe someone who knows gcc better might know what is going on, or if there is something I did wrong.

I just ran "build.sh build" in /usr/src.

Huff:/usr/src> uname -a
NetBSD Huff.BQTnet.SE 8.99.35 NetBSD 8.99.35 (Krille) #2: Tue Mar 19 11:16:12 CET 2019 root%GW.SoftJAR.SE@localhost:/usr/obj/sys/arch/vax/compile/Krille vax


libtool: compile:  cc -DHAVE_CONFIG_H -I. -I/usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/lto-plugin -I/usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/lto-plugin/../include -DHAVE_CONFIG_H -DNETBSD_TOOLS -DTARGET_SYSTEM_ROOT=0 -DTARGET_SYSTEM_ROOT_RELOCATABLE -Wall -O -c /usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/lto-plugin/lto-plugin.c  -fPIC -DPIC -o .libs/lto-plugin.o
/bin/sh ./libtool --tag=CC --tag=disable-static  --mode=link cc -Wall -O -Wc,-static-libgcc  -module -bindir /usr/src/obj/tooldir.NetBSD-8.99.35-vax/libexec/gcc/vax--netbsdelf/6.5.0    -o liblto_plugin.la -rpath /usr/src/obj/tooldir.NetBSD-8.99.35-vax/libexec/gcc/vax--netbsdelf/6.5.0 lto-plugin.lo  -Wc,../libiberty/pic/libiberty.a
libtool: link: cc -shared  .libs/lto-plugin.o    -static-libgcc ../libiberty/pic/libiberty.a   -Wl,-soname -Wl,liblto_plugin.so.0 -o .libs/liblto_plugin.so.0.0
ld: cannot find -lgcc_eh_pic
ld: cannot find -lgcc_eh_pic
nbgmake[2]: *** [liblto_plugin.la] Error 1
nbgmake[2]: Leaving directory `/usr/obj/tools/gcc/build/lto-plugin'
nbgmake[1]: *** [all] Error 2
nbgmake[1]: Leaving directory `/usr/obj/tools/gcc/build/lto-plugin'
nbgmake: *** [all-lto-plugin] Error 2

GCC is now a C++ program.  I remember from long ago that bootstrapping some of the core C++ libraries is a bit tricky.

Ran through a new update yesterday, and tried again.
Got a different problem, but in the end still fails building gcc itself.
(Which is kindof disappointing, since last I tried before this round, I usually was hitting problems later than this.)

Problem this time:

Huff:/usr/src# uname -a
NetBSD Huff.BQTnet.SE 8.99.36 NetBSD 8.99.36 (Krille) #3: Fri Mar 22 06:30:30 CET 2019 root%GW.SoftJAR.SE@localhost:/usr/obj/sys/arch/vax/compile/Krille vax


c++ -fno-PIE -c -DIN_GCC_FRONTEND -O -DIN_GCC -DCROSS_DIRECTORY_STRUCTURE -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -DHAVE_CONFIG_H -I. -Ic -I/usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc -I/usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/c -I/usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/../include -I/usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/../libcpp/include -I/usr/src/obj/tooldir.NetBSD-8.99.36-vax/include -I/usr/src/obj/tooldir.NetBSD-8.99.36-vax/include -I/usr/src/obj/tooldir.NetBSD-8.99.36-vax/include -I/usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/../libdecnumber -I/usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/../libdecnumber/dpd -I../libdecnumber -I/usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/../libbacktrace -DNETBSD_TOOLS -DTARGET_SYSTEM_ROOT=0 -DTARGET_SYSTEM_ROOT_RELOCATABLE -o c/c-decl.o -MT c/c-decl.o -MMD -MP -MF c/.deps/c-decl.TPo /usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/c/c-decl.c /usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/c/c-decl.c: In function 'tree_node* finish_enum(tree, tree, tree)': /usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/c/c-decl.c:8193:1: error: unrecognizable insn:
(insn 72 71 73 16 (set (reg:SI 165)
        (subreg:SI (mem:DI (plus:SI (mult:SI (reg:SI 162)
                        (const_int 8 [0x8]))
(reg/f:SI 103 [ _188 ])) [14 *_206+0 S8 A32]) 4)) /usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/wide-int.h:795 -1
/usr/src/tools/gcc/../../external/gpl3/gcc.old/dist/gcc/c/c-decl.c:8193:1: internal compiler error: in extract_insn, at recog.c:2287
no stack trace because unwind library not available
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://www.NetBSD.org/support/send-pr.html> for instructions.
nbgmake[1]: *** [c/c-decl.o] Error 1
nbgmake[1]: Leaving directory `/usr/obj/tools/gcc/build/gcc'
nbgmake: *** [all-gcc] Error 2

*** Failed target:  .build_done


Johnny Billquist                  || "I'm on a bus
                                  ||  on a psychedelic trip
email: bqt%softjar.se@localhost             ||  Reading murder books
pdp is alive!                     ||  tryin' to stay hip" - B. Idol

Home | Main Index | Thread Index | Old Index