Subject: New to NetBSD/Vax, trying to bring up a MVII
To: None <>
From: Mr Ian Primus <>
List: port-vax
Date: 08/12/2007 07:34:27
Hello - please don't be too hard on me... I'm new to
NetBSD/Vax, and I'm attempting to load it onto a
MicroVax II...

So, here's what I have so far:

This MicroVax II is in a third party cabinet (Sigma
Designs) and has a Dilog ESDI controller, and a TK50
with controller. The original disk was bad (screeching
head crash), so I replaced it with another ESDI disk I
had laying around. I formatted it under the Dilog
onboard firmware formatter. All seems well with it. I
cleaned the TK50 drive, and checked that it loads and
unloads tape.

I have a SCSI TK50 drive, so I cleaned it, and hooked
it up to my PC. I verified that the drive worked, and
was able to read in a cartridge (the only good TK50
tape I have) and erase it. I downloeded boot.fs from a
NetBSD mirror, and went to write it to tape:

dd if=boot.fs of=/dev/nst0 bs=512

The tape whirred to life, and proceded to shoeshine
back and forth. A lot. It makes very, very slow
progress through the cartridge. I let it run, and
eventually (after over an hour) it had spooled almost
all the tape out of the cartridge and onto the takeup
reel, and stopped with an I/O error. I rewound and
ejected the tape and tried it in the Vax anyway. It
starts to read, and then shoeshines back and forth. I
shut it off after a minute ot two, it didn't seem to
be moving tape through, just back and forth.

If I write the tape with:

dd if=boot.fs of=/dev/nst0 bs=16k

it'll write with shoeshining, but not as much as
before, and finish successfully before it has pulled
all of the tape out of the cartridge. Trying to boot
it on the Vax causes it to read through the tape
seemingly to the end of the data, then crash with
SCB2NDINT, MUA0. Probably due to the improper block

So - what am I doing wrong? BTW - the box I'm trying
to write the tape from is running Linux, in case you
were wondering...

Any help would be appreciated - thanks!