Subject: Disk corruption issues
To: None <>
From: John Klos <>
List: port-vax
Date: 11/22/2002 02:30:52

I am seeing a very strange problem on my VAX. I have two disks - a four
gig (boot drive) and a nine gig (other non-crititcal stuff).

Both drives worked fine for a long time, but the nine gig started having
problems where it would say it wasn't clean on reboot. After a few months,
I decided to replace the drive with another nine gig. I also checked and
tested the cables and rechecked the termination, and all that other more
obvious stuff.

The new drive is exhibiting similar problems. All along, I've updated the
OS (am running 1.6-release compiled in late October), so this problem may
have started happening as a result of OS updates, but it was not obvious
enough that I was able to correlate it to a specific change.

The situation: I run disklabel -i /dev/sd1 and set up:

#        size    offset     fstype  [fsize bsize cpg/sgs]
 a:  17783112         0     4.2BSD   2048 16384   118   # (Cyl.    0 - 5292*)
 c:  17783112         0     unused      0     0         # (Cyl.    0 - 5292*)

I run newfs /dev/rsd1a and mount it with this in my /etc/fstab:
/dev/sd1a	/usr/sandbox	ffs	rw,softdep	1 2

I then start to try to set up a bulk build. But, if I even untargzip
pkgsrc.tar.gz on it, then unmount it, then fsck -f it, I get things like:

gaia: {45} fsck -f /dev/sd1a
** /dev/rsd1a
** File system is already clean
** Last Mounted on /usr/sandbox
** Phase 1 - Check Blocks and Sizes
** Phase 2 - Check Pathnames
SIZE=0 MTIME=Dec 31 19:00 1969

REMOVE? [yn] y

SIZE=0 MTIME=Dec 31 19:00 1969

And so on, and so on...

Is there something really simple that I'm missing?

(A note - all hardware issues have been examined; the drive was thoroughly
tested elsewhere, the cable was tested by swapping the connectors between
the boot drive and the second drive without any difference, and so on.)

Thanks much,
John Klos
Sixgirls Computing Labs