Subject: VAXstation 2000: the lost weekend
To: None <>
From: Russell Pavlicek <>
List: port-vax
Date: 12/09/2001 19:53:49

I just tried to install NetBSD on an old VS2000 I had
sitting in the basement.  It simply has an MFM disk in
the box with a thinwire ethernet, so I had to do a
network boot.  After trudging through various docs, I
managed to set up my Linux box to serve as a MOP
loader and NFS server.  I finally got the installation
process to begin when I got my first surprise:

(1) The boot kernel does not recognize the RD5x disks
in the VS2000.  The generic kernel does, however.  So
I spent more time setting up a workable NFS situation
that would allow me to netboot off the generic kernel
and do the install by hand.  When I finally got
everything installed, I discovered my second surprise:

(2) There is no X server.  There are tarballs to
install, references to how much space to allow for X,
etc.  But there is no server.  And there's not a
single note to that effect that I can find in any of
the install docs.  Something should be said somewhere
that there is no X server.

But just when I thought I had a working X-less system
to play with, I discovered that I had no swapfile. 
Why?  Because the partition table was wrong.  Further
experimentation showed why:

(3) disklabel acts like it writes the partition table
when you do a "W", but when you quit and re-enter,
nothing has changed.  No error message is found and no
partition info is written.  When I newfs'd rd0a, I
ended up doing the entire disk.  I have gone as far as
reformatting the drive under the VS2000 console (T
70), but I cannot change the darn partition table.

I have worked on this for about 26 hours this weekend
and I have nothing more to show for it than a
non-graphical diskless workstation.

Anyone have any hints to share with me?


-- Russ Pavlicek

Do You Yahoo!?
Send your FREE holiday greetings online!