Subject: booting 1.4 from TK50 fails
To: None <>
From: Larry Stone <lcs@MIT.EDU>
List: port-vax
Date: 07/19/1999 18:17:12
I'm trying to install NetBSD 1.4 on a MicroVAX III: KA650 in a BA123,
with 8Mb of memory, TK50 controller, DELQA, and DiLOG MQ696 (ESDI +
floppy) MSCP disk controller, with an ESDI disk.

So I made a boot tape on a handy Ultrix MAXINE box with a TZ30, using
  dd if=/afs/ \
     of=/dev/nrmt0h bs=512

(also tried one with the default blocksize, it acts exactly the same)

The checksum on the tape checks out with the ones listed.  The VAX setup
passes diagnostics on the diagnostic TK50, for what that's worth.
Booting it encounters the following problem:

[after "boot mua0"]
>> NetBSD/vax boot [May  7 1999 06:49:43] <<
>> Press any key to abort autoboot 0
> boot netbsd

[at this point, a bit of the "twirling line" appears, the "- \ | / -" pattern
 to show activity, but it's overwritten by the next line: ]

boot failed: No such file or directory
> boot netbsd.gz
boot failed: Not a directory
> boot netbsd.old
boot failed: Not a directory
> boot gennetbsd
boot failed: Not a directory

...The last line is the prompt but everything I try gets either
"Command failed: Not a directory" or a usage message, e.g. "boot rom()netbsd"
fails with "usage: boot [filename] [-asd]".  Couldn't boot "copy" or "edlabel"

I tried pressing a key to abort the autoboot but it didn't seem to make
any difference, it just kept counting down.

Is this miniroot not supposed to work on a TK50?  The READMEs
in the installation directory point to it.

Yeah, I know I should just boot it from the net, but that's complicated
by the fact that other bootparam servers are running on my local net with
defaults that tend to respond faster than mine.  I'd also like to bring
the machine up by its own bootstraps.

thanks for any ideas,

    -- Larry