Subject: Boot code upgrading
To: None <>
From: None <>
List: port-vax
Date: 02/24/1999 16:47:50

we (a colleague and myself) recently made an attempt to upgrade
from NetBSD-1.3 to NetBSD-current on our BA-123-mounted 3500.  We
have so far made two unsuccessful attempts, and they went like

 o First tried to boot / with old boot code.  That
   failed -- it appeared to load most of the code (three or four
   +-separated numbers had been printed) and then executed a HLT

   That's probably not a big surprise, I understand we need to
   upgrade the boot loader code.

 o For the second try we installed the boot code on ra1 (which holds
   /usr on our system) using "disklabel -B", together with a copy
   of the new /boot and

   (Oh, BTW, it's a little confusing that a machine-dependent
   "installboot" man page is available while no installboot
   executable appears to exist.)

   Booted with "b/3 dua1", and got the prompt from the new boot
   loader.  At that point, no matter what we tried to load, be it
   "netbsd" (should by default be from the same drive the boot
   code was loaded from, right?), "ra(0,0)netbsd" and
   "ra(1,0)netbsd", and all caused the boot code to execute a HLT
   instruction, dropping back to the >>> prompt.

   So, it appears that the new boot code can't load any kernel,
   be it old or new...

At this point we're a little short on ideas about what to try
next, and appear to be stuck at 1.3 for the moment.  We do
however note that the freshly built first-stage boot loader is
smaller than the old first-stage boot loader: 7800 bytes vs.
8080 bytes, while the new second-stage loader is larger (34144
vs. 31480).

The source code the boot code is built from is of Feb 18 vintage,
and we have not updated our compiler yet.

Any ideas about what we should do to fix this?

- H=E5vard