Subject: TK50 Boot tapes: What I've found and help needed...
To: None <>
From: Bruce Lane <>
List: port-vax
Date: 01/01/1999 14:04:46
	This is both a request for assistance, and a giving of some information that those writing TK50 boot tapes on a Linux box may (I hope) find useful.

	I've been experimenting with doing exactly the above, using a TK50Z-FA SCSI TK50 drive connected to a 486/66 running Red Hat Linux 5.1. I'm using the TK50 image files for NetBSD 1.3.2.

	My first attempt didn't go so well; the tape drive sawed back and forth for nearly three hours on the second file before dd spat back an error message.

This was solved by using the following command prior to writing the tape:

	mt -f /dev/st1 blksize 512

	Repeating the dd command to write the file to the tape produced a much quicker turnaround (less than 5 minutes), and what appeared to be correct block counts for records in and out.

	Now the problem: I tried booting my MV-III (KA650 CPU, 24 megs RAM) from the newly-created boot tape. It appeared to start OK, but after about two minutes of tape-seeking noises the system simply stopped in midstream. The 'Run' light remained on, but nothing else happened.

	My speculation: The tape I used for the boot image was originally a VMS-initialized backup tape. I did not erase it or otherwise initialize it prior to attempting to write the boot image to it. I feel that this may have had negative effects on my boot attempt.

	I am currently erasing the tape using mt -f /dev/st1 erase. Once this is done, I plan to write three EOF's to it using mt -f /dev/st1 weof 3.

	After that, I will try writing the boot image once again. We'll see how successful I am in actually booting the silly thing.

	Advice or comments would be much appreciated. Thanks in advance.


Bruce Lane, Owner and head honcho, Blue Feather Technologies


Amateur Radio:(WD6EOS) <bold>E-mail:

</bold>SysOp: The Dragon's Cave (Fido 1:343/272, 253-639-9905)

"Our science can only describe an object, event, or living thing in our
own human terms. It cannot, in any way, define any of them..."